DataDear Not Appearing in Office 365 Excel

help

#1

Hi Folks,

I downloaded and installed the latest DataDear software onto my computer:

Windows 10 Enterprise Version 1903 OS Build 18362.175

The install appeared to run through successfully however after launching Excel I did not see the DataDear tab. I’m running:

Microsoft Excel for Office 365 MSO (16.0.11727.20222) 32-bit

I did see the other posts on this forum but the mentioned articles haven’t helped:

When I tried the above COM add-in method the DataDearLoader doesn’t appear at all. I can however Add… and navigate to:

C:\Users\username\AppData\Roaming\Scope SaaS\DataDear but selecting DataDear Loader.dll results in an error:

‘C:…\DataDear Loader.dll’ is not a valid Office Add-in.

I also looked at:

But this doesn’t seem to be the issue either.

Any suggestions?

Thanks,
Dave


#2

Hi Dave

Thank you for reaching out! Are you installing on a server or virtualised environment by any chance?


#3

Hi Clifton,

No, its on my Acer laptop, nothing virtualized.

Thanks!
Dave


#4

Hi Dave

Do you have any anti-virus or firewall software which might be blocking DataDear from updating and loading? If the problem persists, we can organise a remote session so we can have a look and help out with the installation.


#5

Hi Neville,

I do have antivirus/firewall software but I disabled it, removed DataDear, downloaded the latest version, reinstalled it - and still no luck.

I can see what appears to be the correct files. In the same directory mentioned in my original post I have:

  • DataDear Loader.dll
  • DataDear Utils.dll
  • DotNetZip.dll
  • Microsoft.Office.Tools.Comon.v4.0.Utilties.dll
  • Microsoft.Office.Tools.dll
  • Microsoft.Office.Tools.v4.0.Framework.dll
  • Newtownsoft.Json.dll
  • NLog.dll
  • ObjectListView.dll

Thanks,
Dave


#6

Hi Dave

You have less files than a normal installation - something on your PC is deleting some files and hence DataDear cannot load. This is what I see in my DataDear installation folder:

image


#7

Hi Neville,

Can you verify that the file available from here:

https://apps.datadear.com/downloadAddon

Actually has those files in it?

I’ve even tried removing the antivirus, no luck.


#8

Hi Neville,

I was able to install it on another computer using the Advanced Setup (didn’t try the basic setup). Here is what I’m noticing:

  • The working computer is running Windows 10 Pro while the non-working one is running Windows 10 Enterprise.
  • Both are running the exact same build: 10.0.18362
  • Both are running the exact same build of Excel: Excel for Office 365 MSO (16.0.11727.20222) 32-bit
  • The additional files are present on the working system (10 Pro) but not on 10 Enterprise.
  • Manually copying and pasting the files from the working system to the non-working system doesn’t result in the add-on working, even if I attempt to add it manually via COM Add-ins in Excel (shows up as not valid)

Any thoughts? Any possibility the issue is Enterprise?

While there doesn’t appear to be any difference, worth noting that the working Office 365 is from my personal account while the non-working version is from our organization’s Office 365 account - although it appears to be the exact same version.


#9

Hi Dave

The Windows version should not have any impact on DataDear as long as the base software is installed (Win 10 comes preloaded with all prerequisites). In the meantime I am glad you managed to have it work on another machine since this excludes any network problems.

You may want to have a look at this to capture the error from VSTO - https://help.datadear.com/article/5745207463116800/how-do-i-enable-vsto-error-display-alerts-in-excel


#10

I am having the exact same issue but unfortunately I only have one laptop so can’t get it to work at all. Raised a ticket with DataDear but no response.

I tried adding the VSTO but this doesn’t work as the problem remains - when I open Excel and navigate to where the DataDear files are, it can’t find an add-in file. See screenshot.

I’m running Excel on Office 365, and Windows 10 on my laptop, no firewall. It just won’t work. It’s a concern as I have recently changed jobs and implementing a new accounting system, DataDear is really important to gain the planned efficiencies.

What’s the solution DataDear?

Thanks.


#11


#12

Hi @Richie3000

Did you have a look at this article to make sure you have the correct office version installed in your system?

If you have the ‘Trusted Microsoft Store’ version you need to re-install office as suggest in the article.