Datadear not working after update - VAT due in 4 days!

After update DD not functional and gives error messages per attached, need to submit in 4 days so any help greatly appreciated. Has been working fine for over a year, Excel 2016 on Windows 2012R2 on iMac via VMWare Fusion 8.5.10 and has been nice and stable so far.

I’ve got the same issue. I’ve deleted the organisation and fully uninstalled Datadear from my computer. I re-installed and connected the organisation and I’m still getting the message below. We also have to submit our return this week!

I finally got a working system late yesterday and managed my submission, thank goodness. The steps I took are as follows, hope something helps as I can’t be certain exactly which step cured the issue.

  • Updated a little used Windows 10 computer with current updates.
  • Installed Office 365 on it.
  • Downloaded and installed the Office 365 beta version of the Datadear add-in.
  • Re-authorised it with HMRC as a precaution.
  • Dismissed it as no time to learn it so downloaded the standard Excel add-in.
  • Downloaded a fresh MTD template, version 1.2
  • Ran it in Excel, the UI runtime issues did not appear but I still had no connection to HMRC although I could select my organisation so the add-in it was talking to Datadear.
  • Logged on to Datadear and check the organisation setup which looked OK.
  • Tried to connect again but no joy.
  • Logged back into Datadear and set up a fresh entry for the organisation.
  • Re-authorised the new organisation with HMRC.
  • Connect again with the new organisation and this time got the response from HMRC with the VAT period.
  • Prepared income and expenditure on the old system preparatory to transferring the data to the new system for submission as the new PC was not able to connect to my database.
  • Once form complete, on a whim tried to connect on the old system with the new organisation and to my surprise got the HMRC handshake.
  • Very quickly hit ‘Post’ and received the HMRC confirmation - success!

I still got the Custom UI errors but I suspect now that was a Windows/Excel thing. If I had to guess the success steps it would probably be setting up a completely fresh org and re-authoriding Datadear with HMRC, possibly also a fresh install of the add-in and a fresh copy of the template. Hope this helps in some way, best of luck!

2 Likes

Hi @jima ,

Thank you for your response, glad this worked.

@ECEnglish I have checked this internally and there have not been any changes from our side as DataDear. This could be an issue originating from HMRC directly or from your local environment. I would suggest following the above comment from Jima as after updating his Windows and re-connected to HMRC, this worked for him.

Hi Clifton,

I’ve followed the steps above and also removed and re-installed both office 365 and Datadear. I’ve deleted the organisation and added again as a new one and authorised through HMRC. I’ve downloaded the template from the site and logged in again but the auto fill cells only pull through the VRN and not the VAT period. It also still gives me the same message saying to ‘contact support’. It doesn’t give me the option to post online after showing this message, even if I manually enter the dates.

Thanks

I’ve also logged into the HMRC portal to check the software listed and Datadear is no longer showing?

If you haven’t done it already, click the ‘Connect to HMRC’ button from the ‘Organisations’ menu option in your Datadear account and make the entries from there again. ISTR I was able to authorise from there. The HMRC web site is only really a guide, not a definitive list.

BTW my backup plan was to ask my accountant to submit my entries on my behalf if all else failed. Perhaps that may be an option?

Hi @ECEnglish ,

I would suggest trying to get the Obligations report to confirm you have an open period to submit. You may find instructions on how to get the report here:

The dates cannot be entered manually, as it would not work, so I suggest using a new non-edited template.

Hi Clifton,

Thank you for your reply. I’ve opened excel and logged into the Datadear tab and selected our organisation. I’ve then selected the obligation report below it but when I generate the current sheet with the dates selected for the return it still gives me the same error message below. It still pulls through the VRN to the report

Hi,

Our IT team has re-installed office again for my account and I followed the steps above again and it is still not pulling through the return period, only the VRN number. I’ve never had any issues with the software until now. Is there anything else I can try, or could you please recommend a different MTD software to use?

Thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.