Invoice Template giving - the access token error

xero

#1

Hi
We keep getting this message:
Oops - the access token for this organisation has not been authorised or has been revoked. Please re-connect the organization: XXXXXX by using the Add Organisation button in the DataDear toolbar.
Follow instructions on screen to have this re-connected.

There is no active Add Organisation button, nor any further instuctions.

We have reported a problem from add-in, but got no confirmation or tracking code to see if our request is being handled by anyone.


#2

Hi Marija,

Thanks for reaching out! We had replied within the ticketing system and awaiting further feedback for the investigation.

Looking forward to hearing back from your end!


#3

Hi Marija - this means that you are a user and only the DataDear account owner can add the organisation. You will need to ask him/her to reconnect the Xero organisation.


#4

Hi Neville

We did so, he has the same problem. He also sent a feedback via DD add-in in Excel.

We managed to use template for bank account transfer yesterday, but invoice template still has the same problem. So I would guess that this is not an authorization issue, but a template problem. We used this invoice template many times before. We see that you now have new templates, but I guess that the “old” ones should still be working?

Tnx
Marija


#5

Hi Marija,

Yes, correct, previous version of the templates will still work. The problem had been identified and being investigated by the team.


#6

Hi Clifton

Do you have any idea when we can expect to have this problem solved? We cannot use invoice template for almost a week now and we are late with our reports.


#7

Hi Marija

There is an ongoing investigation about this and hoping this will be identified soon. I will let you know once we have feedback available.


#8

Hi, any news? DD is not functional for 10 days now, if you cannot solve this, let us now so we don’t waste any more time on this and find another way for bulk upload (xero csv files) :confused:.


#9

Hi Marija
This problem has been identified and will be fixed by the next release - we are currently working on finding a workaround so you may still be able to use the POST functionality.


#10

Hi, I am the owner of the organization and I have reconnected the organization multiple times, but with no success in the end.


#11

Hi, could you tell us when the next release is due?


#12

Hi @marko.nikolic - the next release is due on the 11th September. With regards to your problem, is this happening when trying to post using the Invoices Template? This case is quite unique even if the error message might be the same.


#13

Yes, Marija and I tried to upload the Invoices template on two different computers using different logins. Same error.


#14

Hi Marko - apologies - I was not aware you are referring to the same case. There is something in the static data of your specific organisation which is not allowing the template to be loaded correctly hence cannot be used. Now that it has been confirmed that this is a very specific problem, we should be able to identify the exact line which is causing the problem. Typically this is a contact, item, tracking or an account - In any case, you will be informed once this is identified.


#15

A post was split to a new topic: P&L report multiple periods giving Ooops error on Xero UK


#16

A post was split to a new topic: HMRC template - Oops error


#17

Hi Marko

A follow up on this - the team confirmed that the problem was related to an old currency code supplied by the Xero api which was not allowing the Invoices template to be populated. This has now been addressed and it will be fixed in the next release on the 11th September.


#18

Dear DataDear team

We updated DD add-in, but we still cannot post to Xero. Messages we receive:
9 Tax Rate The data entered for Tax Rate is not valid. Please fix the error and try to post again.
9 Account The data entered for Account is not valid. Please fix the error and try to post again.

Drop-down menus for these fields are not active.

Please help
Marija


#19

Hi @Marija

I will check with the dev team and revert.


#20

Hi @Marija

I was told that the fix for this problem did not pass through the quality team and did not make it in time for this release.

If it helps, they indicated that the problem is the currency “Zambian Kwacha” which is marked as expired from Xero and cannot be displayed by DataDear. By the next release a patch to resolve this problem will be released. In the meantime, is it possible to remove that currency from Xero? If you can do that, you will be able to use the sheet without any problems.