Oops... message - VAT returns

Hi
I keep getting the following message day after day when trying to submit my MTD VAT return using the DataDear free excel add-in:
“Oops … There has been an unexpected error returned from HMRC. Please try again later and if the problem persists, please click the Report Problem icon in the DataDear toolbar so we can investigate.”

I have tried everything I can think of to resolve:

  • deleted and reinstalled the add-in
  • removed and re-granted authority for the add-in in HMRC’s portal
  • deleted and re-added my organisation in the DataDear dashboard…

Please can you help me - I have separately reported the issue using the “Report Problem” icon

I have until 7 April to file my VAT return and am keen to resolve before then!

Thank you - do appreciate your support for what is free software!

Leigh

Hi LeighB
I’m having exactly the same problem since yesterday and have also tried the delete regrant auth etc.
I am getting the VAT number being populated but not the date after populating the VAT number it churns away then spits out the Oops error exactly as you state.

I have also signed into HMRC account and everything seemed fine there, it showed I had a return to do up to end Feb and needed to submit by 7th April.

As for reporting the error Datadear all they did was point at this forum then close the ticket. Then want me to rate the response!

We seem to be in the same boat - I get the VAT number populated too…
Hopefully we hear back from DataDear soon…?
Leigh

My problem seemed to resolve itself a few days later…

Yes after 3rd attempt today my problem has resolved itself also

I am having the same problem with the same lack of help. I have made the return for the last year and nearly always with problems.

There is no issue with our accounting period, no problems with the VRN and I have deleted all accounts, uninstalled and re-installed datadear and re-authorised. Still the same problem and still the same response from datadear that only this forum can help (it would appear that you have to pay to have the product work)

As it appears that it just resolves itself for no reason that any of us can see, I wonder what the point of insisting we post on here?

Deeply frustrated.

Hi Denise,

did you manage to fix it?
I am facing the same any advise.

Regards,
Sameh