Template Error when posting to Xero

I have an issue with the Journals template for Xero.

I created a master journal and workings for the monthly prepayments and the used this for April to post as Draft Journal in Xero which worked fine.

I have now reused the same journal for May having changed the date and tried to post this.

However it will not post as I get an error “ The status “DRAFT” cannot be applied to the document”.

Are you able to assist with this?

Many thanks

Hi @Ecarr

If you have used the template before, can you check the last column P “Xero Edit ID”. This might still contain the Xero ID of the previous post into Xero. When DataDear finds a record in that column, it will try to edit the previous record in Xero. I suspect this has been approved by now hence the previous manual journal cannot be edited.

Thanks - now working once I remove the details in column P.

Thanks for the feedback and glad that worked! :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.