Token not authorised or revoked

hi,

have been using datadear for months without issues with xero.
recently added a new company to xero and to datadear and was not able to pull data into datadear (as a user). each time i would get the error:
“Oops - the access token for this organisation has not been authorised or has been revoked. Please re-connect the organization: {company name} by using the Add Organisation button in the DataDear toolbar.
Follow instructions on screen to have this re-connected.”

then the “owner” of the account would do as requested and it would work for a few hours but then later on or the next day the same error comes up again.
at first it was only the new company that was added but now previously working companies in the group are failing to load also.
this is not related to a specific report but any report that is tried to run gets this error.
have seen similar topics and we have “deleted” and then re-added the new company in datadear but just got the same error again today.
it is simply not workable to get the “owner” to reconnect the account everytime we need a report updating.
please advise

Hi @cbritnell

Thank you for getting in touch.

When signing in to Datadear from excel are you using your username and password or are you using the sign in with Xero button?

Regards,

David

hi,

i was using the xero button but tried other way and it works now.
thanks,

if this is a known issue might be good to make this easier to find out.

1 Like