Token revoked / can't add company

OK, we received an error saying access token has not been authorised or has been revoked.

I logged into the website (I am owner of the account). Said I should re-add the organisation.

Tried to do that but couldn’t select the company from the drop down menu as it was greyed out and it said already connected. Then deleted the organisation so I could re-add it.

Company is gone from the list of organisations on the website but when I try to add it, the name still appears as already connected.

We are preparing for audit starting next week and are now unable to proceed. I need an urgent fix and contact from an actual person from Datadear.

1 Like

I’m in exactly the same situation. None of my staff can post to Xero at the moment. Urgent help required! I even removed DataDear from Xero so I could add it back in, but the error message persists.

I have also emailed - no reply yet.

Good luck! Will post on here if we get a solution.


1 Like

I am in the same problem as well. Excel add-in revoking token to our systems. Message says to Add organisation from the DataDear Ribbon by clicking “ADD” button, but my button in Excel is greyed out but I can still see all the organisations in the other section of the ribbon. This is also stopping us for working, so needs an urgent response from DD on this please.

Same issue happening for my clients, this was reported to me yesterday late afternoon, thought I would leave to see if it fixes itself, still an issue this morning. Hopefully this can be resolved asap.

Hi all!

Can you try following these steps to see if you manage to use the organisation;

It is important that the organisation is deleted from the DataDear dashboard as well before re-connecting.

We recently launched this functionality, the users can go to the Organisations tab in the DataDear website and click on the “Connect to Xero” button like you would when connecting an Organisation for the first time. Scroll to the bottom of the page and click the big blue “Continue with” button at the bottom of the page. This should reset all your connections and solve similar issues.

More information on how to connect an organisation can be found here:

Hi @AlecT
Only the DataDear account owner (and authorised users) can add or re-add organisations to DataDear. Button will be disabled for users without this permission.

Hi - well that makes no sense. Our guy in charge of the account has checked and I am still have all the organisations linked to me in the setup part. I can also see all of the organisations, select them and select the data tables and DataDear Reports in Excel. So why would I then need to relink something that is already linked in the DataDear controls, and is visible in Excel ?


I had already disconnected Datadear from the organisation under Connected apps.

I still can’t add it as it continues to show as connected in the dropdown menu.


You may use the blue button to reconnect all companies if it is already connected (greyed out).

Just click on the Continue with x organisations button.

Ok, after repeating the above process a few times that company is now working. I tried to run my report and now the next entity has the same token revoked error. I have 17 companies to report on.

Why is this happening?

By the way, for any other users. I found that after hitting blue button “Continue with organisations”, I had to go back into Xero, disconnect Datadear again, then go back into Datadear and do the add Xero company process. It then appeared for selection in the drop down menu.

1 Like

I’m finding this same issue now happening across all my clients as well - not had a problem like this since I started using Datadear a few years ago

I have to delete from the dashboard, delete the link from within Xero and then re add everytime… getting a bit frustrating!

Hi @Sidgrove

There was recently a change from DataDear to make the reconnection with Xero more stable and this has caused some connection tokens to require a complete reconnection. We were not expecting this change to cause disconnections as this behaviour was not experienced in the test environment. It seems the Xero API is forcing some DataDear users to re-establish the connection possibly for security reasons - we have limited control on when the Xero API triggers a request for reconnection.

Reconnecting is fairly easy and this can be done by following the usual reconnection steps. This can happen from time to time as the handshake between DataDear and the api provider changes every 30 minutes.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.